忍者ブログ
カマキリが好きな管理人が主にプログラミングに奮闘する日記です。更新は不定期です。
[87]  [85]  [84]  [83]  [82]  [81]  [79]  [78]  [76]  [75]  [73
×

[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。

どうしてもカラー印刷しなければならない状況に陥ってしまったので、
Canon ip2600プリンタをubuntu10.04で動かしてみることにしました。

まず、Canonの公式サイトでLinux用のドライバを探してみます。

http://cweb.canon.jp/drv-upd/ij-sfp/bjlinux290-ip2600.html
↑ip2600のLinux用ドライバのところです。

ここを見てdebianファイル2つと操作説明書(HTML)を入手して、いざやってみると、
依存関係がどうのこうの出てインストールできません。
どうやら原因はlibcupsys2がないことみたいです。

そしてまた調べてみると、ありました、libcupsys2をlibcups2に書き換える方法が!
https://forums.ubuntulinux.jp/viewtopic.php?id=12356
↑ubuntu日本語フォーラム

さっそくダウンロードしてホームディレクトリに置いておいたdebianファイル2つを上の方法で、
元がバージョン1だったのでバージョン1.1として作り直して、インストールしたら上手くいきました。
そしてPCを再起動してみると、
b5ec689f.png


プリンタの追加とかはまだしていなかったはずですが、なぜか追加してありました。
印刷も上手くいき、ドライバを見ても作るまでなかったip2600のが使われていたので大丈夫みたいです。

これでやっとカラーで課題が提出できる・・

拍手[0回]

PR
この記事にコメントする
お名前
タイトル
文字色
メールアドレス
URL
コメント
パスワード   Vodafone絵文字 i-mode絵文字 Ezweb絵文字
カレンダー
08 2017/09 10
S M T W T F S
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
ツイッター
おすすめ記事
カマキリ系
蟷螂山
リンク
カウンター
最新コメント
[01/12 カマキリ]
[01/04 べス]
[07/24 カマキリ]
[07/23 ベス]
[07/23 カマキリ]
プロフィール
HN:
カマキリ
年齢:
24
性別:
男性
誕生日:
1993/07/07
職業:
大学生
趣味:
プログラミング
自己紹介:
カマキリが好きな人です(完)。
ブログ内検索
Copyright(C) 2008-2012 C-MANTIS.All Rights Reserved.
忍者ブログ [PR]
記載されている会社名・製品名・システム名などは、 各社の商標、または登録商標です。